Веб Дизайн - статьи


Установка


Для работы с веб-сервисами потребуется библиотека . Не смотря на то, что облегченная версия этой библиотеки уже включена в стандартную поставку Ruby, настоятельно рекомендуется установить полную версию. Если вы подключены к интернету напрямую, то достаточно всего одной команды:

# gem install soap4r

Bulk updating Gem source index for: http://gems.rubyforge.org Install required dependency httpclient? [Yn] Y Successfully installed soap4r-1.5.8 Successfully installed httpclient-2.1.2 Installing ri documentation for httpclient-2.1.2... Installing RDoc documentation for httpclient-2.1.2... Если вы подключены через прокси, то перед инсталляцией потребуется задать переменную окружения http_proxy. В Линуксе это можно сделать следующим образом:

export http_proxy=http://user:password@host:port Для установки переменной окружения под Windows выберите "Мой компьютер" -> "Свойства" -> "Дополнительно" -> "Переменные среды"-> "Создать".

Если при работе через прокси-сервер вы столкнетесь с ошибкой "407 Proxy Authentication Required", прочитайте . Там описывается решение проблемы.




- Начало -  - Назад -  - Вперед -



Книжный магазин